CSE: When should I upgrade or not upgrade the PolicyPak CSE?

PolicyPak CSE is updated from time to time to add features and fix bugs.

Generally, when we publish an update, we either say:

“This is a recommended update for all customers”
“This is a minor update to fix the following issues.”

It’s up to you to read the build notes and decide if you should upgrade.

But in general, if we state “This is a recommended update for all customers”, then you should almost certainly do that.

That being said, if you are NOT at the latest version of the PP CSE, and you open a support ticket, one of the first troubleshooting steps we ask of all customers is to get on the latest CSE on one or two affected test machines.

If a bug is identified in the latest shipping build, then we will supply a fix and publish a new update.

Said another way, PolicyPak ONLY supports and makes fixes for the LATEST CSE, and never supports any older CSEs.

So staying up to date is advised so that if you do find an issue that requires attention, you’re not months or years behind.